Back to overview
Degraded

Schema Publishing not possible

Nov 02 at 01:36pm CET
Affected services
GraphQL API (Registry)

Resolved
Nov 03 at 01:20am CET

Schema publishes now succeed.

Updated
Nov 02 at 02:34pm CET

Schema publishing is failing due to a legacy fallback that attempts to write to the Cloudflare KV store.

The write is optional as all Hive users use the new R2-based CDN. However, we cannot deploy a fix that removes the legacy writes to KV as our infrastructure for deploying relies on the Cloudflare API, which is currently still offline.

See https://www.cloudflarestatus.com/incidents/hm7491k53ppg

Updated
Nov 02 at 01:52pm CET

The Hive CDN is fully operational. The issues are related to other cloudflare services which let the schema publishing fail.

Updated
Nov 02 at 01:43pm CET

According to https://www.cloudflarestatus.com/, "Cloudflare Dashboard and Cloudflare API service issues" are being investigated.

R2 is not listed.

We see a lot of requests to Cloudflare R2 failing with status code 500, which results in the schema publishing to fail.

Created
Nov 02 at 01:36pm CET

We are investigating an issue in which the publishing of schemas fails.