Degraded performance for schema check/publish due to R2 incident
Resolved
Feb 06 at 12:53pm CET
The S3 mirror responses were not served due to unexpected errors caused by analytics reporting to Cloudflare. We are implementing a fix to prevent this from happening during future Cloudflare R2/Analytics outages.
Affected services
GraphQL API (Registry)
HA CDN
Updated
Feb 06 at 12:31pm CET
The Cloudflare Incident has been resolved. https://www.cloudflarestatus.com/incidents/pgz7g5xlpxzr
We can no longer see any errors within our monitoring. We are still doing an internal investigation on why our S3 mirror did not taking over when R2 was unavailable.
Affected services
GraphQL API (Registry)
HA CDN
Updated
Feb 06 at 12:24pm CET
We are seeing a reduction in errors being reported within our monitoring system. The CDN is recovering.
Affected services
GraphQL API (Registry)
HA CDN
Updated
Feb 06 at 12:17pm CET
Cloudflare posted a status claiming to resolve the availability issues: "A fix has been implemented and we are monitoring the results" (https://www.cloudflarestatus.com/incidents/pgz7g5xlpxzr).
Affected services
GraphQL API (Registry)
HA CDN
Updated
Feb 06 at 12:04pm CET
We have a theory on why the S3 mirror requests are not served, calls to the Cloudflare analytics reporting (which is also affected by the outage) might let requests fail before serving the result.
We are currently blocked from deploying and testing that change to our systems by a GitHub incident (https://www.githubstatus.com/incidents/yhn3m0yqdxmc).
Affected services
GraphQL API (Registry)
HA CDN
Updated
Feb 06 at 11:15am CET
Schema publishes and reads the supergraph/schema/services from CDN that are affected by the Cloudflare outages.
We are investigating why our S3 mirror is failing partially failing to serve the artifacts if it fails to serve them from R2.
Affected services
GraphQL API (Registry)
HA CDN
Created
Feb 06 at 07:28am CET
Cloudflare is having an ongoing incident in the past hour (https://www.cloudflarestatus.com/incidents/pgz7g5xlpxzr). Our solution is based on R2 as primary data store, so schema publish and schema checks are affected at the moment.
CDN is expected to perform without issues, as we have a mirror for reading data from the storage.
We are monitoring and tracking the incident in CloudFlare, and we will post updates here soon.
Affected services
GraphQL API (Registry)